Template for project reports in Quantitative Microscopy

The goal of the practical part of the course is to gain an understanding of the workflow from sample preparation to quantitative measurements for a specific research application. The research application should be defined based on your own research. You have been divided into groups of 1-2 course participants with a background in digital image processing (or similar) and 1-2 course participants from an application area, and you will jointly choose a microscopy system around which you design a quantitative microscopy project. The project should include all steps from sample preparation (where the course participant(s) from the application area acts as the expert, teaching the others), via microscopy, to digital image processing and quantification (where the participant from digital image processing acts as an expert, teaching the others). The project may very well be in line with the course participants' current research activities. The examination of this part of the course will be a written report and an oral presentation for all course participants, including a discussion of the choice of microscopy system. All oral presentations will take place on December 11, 10.15-15. The written report is due the same day. Each group will have 15 minutes for presentation and 5 minutes for questions. It is very important that all course participants are present as this is a mandatory part of the project-part of the course. The examiner (I, Carolina Wählby) and the students will jointly decide the course credits assigned for the project (1-5 ECTS). I will also be available to discuss your project ideas and provide guidance (if needed). Please use the following link to sign up for a time for your group: http://www.doodle.com/sdci8tkcepeg9xhwj. For those projects requiring equipment that cannot be accessed for free (e.g. TEM), please confirm budget with me before getting started.

For sample preparation, documentation of the process is very important. This can be done by taking a series of pictures of the process, and supplement with explanatory text. The documentation should be more detailed, but at the same time less formal, than a typical ‘Materials and Methods’ section of a journal paper. Remember that the course participant from the application area should act as the teacher here. The choice of imaging system should be discussed, including resolution (in all five dimensions), motivation of choice of microscope settings, description of imaging procedure and discussion of sources of noise and sample to sample variation. Finally, for digital image processing, choice of software and discussion of approach should be included. Here, a detailed documentation of each step in the processing pipeline should be included, preferably with an illustration of the result after each step in the processing pipeline. Here, just as with the description of the sample preparation, it is important that the process is documented in more detail but less formally than in a typical journal paper. All reports will be shared with all course participants, but not spread outside the course.

Remember that the level of ambition of the projects is very much up to you (1-5 ECTS), and I strongly encourage continued collaborations outside the scope of the course. The number of points assigned to you is however dependent on the report and presentation you deliver on December 11.

General template
1. Project title
2. Background and general question (hypothesis), e.g. ‘Is it possible to image and automatically detect cilia with STED microscopy?’ or ‘Can stages of sperm development be quantified from images of testicle tissue using local texture filters?’ etc
3. Sample preparation
   - How does sample preparation affect the possibility to extract quantitative measurements from the image data?
   - What are the sources of variation?
   - Alternative approaches outside the scope of this project?
4. Image acquisition
   - Choice and motivation of microscope system
   - Description of system, including resolution (in all five dimensions),
   - Choice and motivation of microscope settings, including detailed description of procedure
   - What are the sources of variation?
   - Alternative approaches outside the scope of this project?
5. Image analysis
   - Choice and motivation of approach
   - Choice and motivation of software, including detailed description of procedure
   - What are the sources of variation?
   - Alternative approaches outside the scope of this project?
6. Conclusion
   - Discussion regarding initial hypotheses.
   - Ideas for future improvements and alternative approaches.
%create a pipeline that loads an image, finds nuclei, cells and blobs, and counts blobs per cell
close all; clear all;
I=imread('blob_image.tif');
figure; imshow(I);
figure; imshow(I(:,:,1));
figure; imshow(I(:,:,2));
figure; imshow(I(:,:,3));

% the nuclei are in the blue channel, while the blobs are in the red
nuclei = I(:,:,3);
blobs = I(:,:,1);

% threshold the blue channel to find the nuclei
bw_nuclei = im2bw(nuclei, graythresh(nuclei));
figure; imshow(bw_nuclei);

% use the distance transform and watershed segmentation to separate touching nuclei
dt_nuclei = bwdist(~bw_nuclei);
figure; imshow(dt_nuclei, []);

% smooth the distance transformed image to get less oversegmentation
h = fspecial('gaussian', 15, 7);
dt_nuclei = imfilter(dt_nuclei, h);
wat = bwdist(~dt_nuclei);
figure; imshow(wat, []);

% build voronoi tesselation from nuclei
dt_sep_nuclei = bwdist(~wat) + 1;
figure; imshow(dt_sep_nuclei, []);
dt_sep_nuclei(wat>1) = 0;
figure; imshow(dt_sep_nuclei, []);

% display result on nuclei, including cell ID
cyto_approx = watershed(dt_sep_nuclei);
figure; imshow(cyto_approx, []);

% limit extent of cytoplasm to 65 pixels from nucleus, and remove objects cut by border
cyto_red = cyto_approx;
cyto_red(dt_sep_nuclei>65) = 0;

% display result on nuclei, including cell ID
cyto_red_no_border = imclearborder(cyto_red);
figure; imshow(cyto_red_no_border, []);

% find blobs and label
bw_blobs = im2bw(blobs, graythresh(blobs));
labeled_blobs = bwlabel(bw_blobs);
figure; imshow(labeled_blobs, []);

% count blobs per cytoplasm
blob_count_per_cell = zeros(1, num_cells);
for i = 1:num_cells
    blobs_in_cell_i = labeled_blobs(cyto_red_no_border == i);
    blob_count_per_cell(i) = length(unique(blobs_in_cell_i));
end
figure; bar(blob_count_per_cell);
Instructions for ImageJ example. Information and documentation about ImageJ can be found at http://imagejdocu.tudor.lu/doku.php.

1. Getting Started
Open ImageJ and load the image blob_image.tif by choosing File->Open in the menu. The image is an RGB image were the red channel shows blobs, the green channel is empty, and the blue channel shows the nuclear (DNA) stain. Split the RGB image into separate channels by choosing Image->Color->Split Channels. Rename the blue (nuclear) channel image to NucleiOrig.tif or similar (Image->Rename) and the red channel images as DotsOrig.tif or similar and save them as you might want to start over with a fresh nucleus or dot image without having to go through the procedure of splitting an RGB image every time. Some general information about the image is displayed in the image window just above the image and some additional can be found by choosing Image->Show Info. When the cursor is moved over the image the current image position and the corresponding intensity value is displayed in the menu window. The image histogram will be displayed by choosing Analyze -> Histogram.

2. Point Processes
You can investigate the NucleiOrig image by choosing Image->Adjust->Brightness/Contrast. Modify the intensity transfer function to alter the intensities in the image by moving the sliders. These adjustments only affect the display of the image, not the image content itself. Segmenting an image using global thresholding is also a point process as it operates on each pixel's intensity value individually and does not take the neighbouring values into account. Go back to your nuclei image and choose Image->Adjust->Threshold. The user has the option to manually choose a threshold or to choose a method that calculates the threshold automatically. Don’t forget to check the Dark background box.

3. Spatial Filtering
More or less noise is often present in an image, and some noise reduction filtering operation is often good to apply prior to segmenting and analyzing an image. Zoom in on two nuclei very close to each other (touching) in our test nuclei image. Go to Process->Filters and try the filters mean, median, min, FindEdges etc. Since our test image is rather nice, test the filters again after having added some noise to the image (Process->Noise->Add Noise).

4. Segmentation
As you previously saw when exploring the thresholding possibilities it was not possible to choose a threshold that created individual objects for each nucleus. It is often necessary to fill holes and split touching objects (on our test image filling holes might not be necessary depending on what thresholding method you have used). Threshold the image and then choose Process->Binary-> Make Binary and Process->Binary->Watershed. Sometimes it is of interest to estimate masks or regions for objects not directly visible in the image. One common example is creating a mask approximating the cytoplasm around each nucleus. This can for example be achieved through Voronoi tessellation of the segmented nuclei image. Make a copy (Image->Duplicate) your binary image of segmented nuclei. Choose Process->Binary->Voronoi. To create a binary image of the different regions the resulting image needs to be thresholded (Image->Adjust->Threshold use a manual threshold from 1-255), binarized (Process-Binary->Make Binary) and inverted (Edit->invert). Once that is done you have created an image with regions approximating the cytoplasms.

5. Object Measurements
Now we have gone through algorithms enabling finding the individual nuclei in our image as well as an approximation of the cytoplasms, and it is time to do some measurements in the image.
Make sure you have a binary image where the nuclei are separated. Choose Analyze->Analyze Particles. Make sure that 'display results' is checked and choose to display outlines. It is quite often the case that intensity measures are of interest. To get some intensity information for each nucleus we need to set what we are interested in measuring, in what image, and using which mask (our binary nuclei image). Go to Analyze-> Set Measurements and choose what you are interested in measuring let’s say area (same as already done above) and mean gray value. What is important now is that you in the Redirect to box choose the image where you want to make your measurements. When you are done click ok. Next make sure your binary nuclei mask image is the active one (click in it). Then go to Analyze->Analyze Particles. Make sure that display results and clear results are checked. Choose ‘No’ on the question that pops up about saving the results (that refers to the previous results). Repeat the procedure to measure the mean intensity under an approximated cytoplasm mask in the image Dots.tif. If you want to overlay your
cytoplasm mask on the original RGB image or the nuclei grey-level image you should also check the Add to Manager box in the Analyze-> Analyze particles window. To overlay the mask once you have analyzed your particles activate the original RGB image and choose Image->Overlay->Show Overlay
Pipeline from CellProfiler Demo. Image and pipeline available on course web page

CellProfiler Pipeline: http://www.cellprofiler.org
Version: 1
SVNRevision: 10997

LoadImages: [module_num: 1][svn_version: '10951'|variable_revision_number: 11|show_window: False|notes: 'This step loads all images with a filename ending with .tiff, in alphabetic order. We also assume that the images are color images, and split them into grayscale images in the next step. If you instead have grayscale images, add all image channels belonging to the same image and define them based on how their names are unique (e.g. "Text that these images have in common" may be something.c1.tiff for the DAPI channel and something.c2.tiff for the channel showing the RCPs. Note that it is possible to load almost any file format.

File type to be loaded: individual images
File selection method: Text - Exact match
Number of images in each group: 3
Type the text that the excluded images have in common: Do not use
Analyze all subfolders within the selected folder?: None
Input image file location: Default Input Folder: \x7CNone
Check image sets for missing or duplicate files?: Yes
Group images by metadata?: No
Exclude certain files?: No
Specify metadata fields to group by:
Select subfolders to analyze:
Resolution of this image in each group: 1
Extract metadata from where?: None

Channel count: 1
Group the movie frames?: No
Grouping method: Interleaved
Number of channels per group: 3
Load the input as images or objects?: Images
Name this loaded object: RGB
Name this loaded image: RGBA_P\x5D\x5B0-9\x5D(2)\x5B_x5D(0-9)\x5D

Channel number: 1
Rescale intensities?: Yes

ColorToGray: [module_num: 2][svn_version: '10318'|variable_revision_number: 2|show_window: False|notes: 'In this step we split the color image and say that the nuclei (DNA) are shown in the blue channel, while RCPs are in the red channel.

Select the input image: RGB
Conversion method: Split
Image type: \x3A: RGB
Name the output image: OrigGray
Relative weight of the red channel: 1
Relative weight of the green channel: 1
Relative weight of the blue channel: 1
Convert red to gray?: Yes
Name the output image: Blobs
Convert green to gray?: No
Name the output image: OrigGreen
Convert blue to gray?: Yes
Name the output image: DNA
Channel count: 1
Channel number: \x3A: Red\x3A 1
Relative weight of the channel: 1
Image name: \x3A: Channel 1

IdentifyPrimaryObjects: [module_num: 3][svn_version: '10826'|variable_revision_number: 8|show_window: True|notes: 'We use the DNA channel to define the cell nuclei.

Select the input image: DNA
Name the primary objects to be identified: Nuclei
Typical diameter of objects, in pixel units (Min, Max): 40, 90
Discard objects outside the diameter range?: Yes
Try to merge too small objects with nearby larger objects?: No
Discard objects touching the border of the image?: Yes
Select the thresholding method: Otsu Global
Threshold correction factor: 1.2
Lower and upper bounds on threshold: 0.000000, 1.000000
Approximate fraction of image covered by objects?: 0.01
Method to distinguish clumped objects: Shape
Method to draw dividing lines between clumped objects: Shape
Size of smoothing filter: 10
Suppress local maxima that are closer than this minimum allowed distance: 4
Speed up by using lower-resolution image to find local maxima?: Yes
Name the outline image: PrimaryOutlines
Fill holes in identified objects?: Yes
Automatically calculate size of smoothing filter?: Yes
Automatically calculate minimum allowed distance between local maxima?: Yes
Manual threshold: 0.0
Select binary image: None
Retain outlines of the identified objects?: No
Automatically calculate the threshold using the Otsu method?: Yes
Enter Laplacian of Gaussian threshold: 0.5
Two-class or three-class thresholding?: Two classes
Minimize the weighted variance or the entropy?: Weighted variance
Assign pixels in the middle intensity class to the foreground or the background?: Foreground
Automatically calculate the size of objects for the Laplacian of Gaussian filter?: Yes
Enter LoG filter diameter: 5
Handling of objects if excessive number of objects identified: Continue
Maximum number of objects: 500
Select the measurement to threshold with: None

IdentifySecondaryObjects:

Select the input objects: Nuclei
Name the objects to be identified: Cells
Select the method to identify the secondary objects: Distance - N
Select the input image: Blobs
Select the thresholding method: Otsu Global
Threshold correction factor: 1
Lower and upper bounds on threshold: 0.000000, 1.000000
Approximate fraction of image covered by objects: 0.01
Number of pixels by which to expand the primary objects: 100
Regularization factor: 0.05
Name the outline image: SecondaryOutlines
Manual threshold: 0.0
Select binary image: None
Retain outlines of the identified secondary objects?: Yes
Two-class or three-class thresholding?: Two classes
Minimize the weighted variance or the entropy?: Weighted variance
Assign pixels in the middle intensity class to the foreground or the background?: Foreground
Discard secondary objects that touch the edge of the image?: No
Discard the associated primary objects?: No
Name the new primary objects: FilteredNuclei
Retain outlines of the new primary objects?: No
Name the new primary object outlines: FilteredNucleiOutlines
Select the measurement to threshold with: None
Fill holes in identified objects?: Yes

IdentifyPrimaryObjects:

Select the input image: Blobs
Name the primary objects to be identified: DetectedBlobs
Typical diameter of objects, in pixel units (Min, Max): 1, 10
Discard objects outside the diameter range?: Yes
Try to merge too small objects with nearby larger objects?: No
Discard objects touching the border of the image?: Yes
Select the thresholding method: Otsu Global
Threshold correction factor: 1
Lower and upper bounds on threshold: 0.000000, 1.000000
Approximate fraction of image covered by objects: 0.01
Method to distinguish clumped objects: Intensity
Method to draw dividing lines between clumped objects: Intensity
Size of smoothing filter: 1
Suppress local maxima that are closer than this minimum allowed distance: 2
Speed up by using lower-resolution image to find local maxima?: No
Name the outline image: PrimaryOutlines
Fill holes in identified objects?: Yes
Automatically calculate size of smoothing filter?: No
Automatically calculate minimum allowed distance between local maxima?: Yes
Manual threshold: 0.0
Select binary image: None
Retain outlines of the identified objects?: No
Automatically calculate the threshold using the Otsu method?: Yes
Enter Laplacian of Gaussian threshold: 0.5
Two-class or three-class thresholding?: Two classes
Minimize the weighted variance or the entropy?: Weighted variance
Assign pixels in the middle intensity class to the foreground or the background?: Foreground
Automatically calculate the size of objects for the Laplacian of Gaussian filter?: Yes
Enter LoG filter diameter: 5
Handling of objects if excessive number of objects identified: Continue
Maximum number of objects: 500
Select the measurement to threshold with: None

Relate Objects: Select the input child objects: DetectedBlobs
Select the input parent objects: Cells
Calculate distances?: None
Calculate per-parent means for all child measurements?: No
Calculate distances to other parents?: No
Parent name: None

Overlay Outlines: Display outlines on a blank image?: No
Select image on which to display outlines: RGB
Name the output image: OrigOverlay
Select outline display mode: Color
Select method to determine brightness of outlines: Max of image
Width of outlines: 1
Select outlines to display: SecondaryOutlines
Select outline color: Red

Display Data On Image: Display object or image measurements?: Object
Select the input objects: Cells
Measurement to display: Children_DetectedBlobs_Count
Select the image on which to display the measurements: OrigOverlay
Text color: yellow
Name the output image that has the measurements displayed: DisplayImage
Font size (points): 10
Number of decimals: 0
Image elements to save: Image

Save Images: Select the type of image to save: Image
Select the image to save: DisplayImage
Select the objects to save: None
Select the module display window to save: None
Select method for constructing file names: From image filename
Select image name for file prefix: RGB
Enter single file name: OrigBlue
Do you want to add a suffix to the image file name?: Yes
Text to append to the image name: res
Select file format to use: bmp
Output file location: Default Output Folder \x7C None
Image bit depth: 8
Overwrite existing files without warning?: Yes
Select how often to save: Every cycle
Rescale the images?: No
Save as grayscale or color image?: Grayscale
Select colormap: gray
Store file and path information to the saved image?: No
Create subfolders in the output folder?: No

Measure Object Intensity: Select an image to measure: Blobs
Select objects to measure: DetectedBlobs

Export To Spreadsheet: In this step we save measurements to a csv file that can be opened in e.g. Excel for further analysis. It is usually a good idea to "Press to select measurements" to limit what measurements you save from your experiment. Note that while in Test-mode, no measurements are saved and there will be a warning sign next to this module in the pipeline.
Select or enter the column delimiter: Comma (",")
Prepend the output file name to the data file names?: Yes
Add image metadata columns to your object data file?: No
Select output to a size that is allowed in Excel?: No
Select the columns of measurements to export?: Yes
Calculate the per-image mean values for object measurements?: No
Calculate the per-image median values for object measurements?: No
Calculate the per-image standard deviation values for object measurements?: No
Output file location: Default Output Folder
Create a GenePattern GCT file?: No
Select source of sample row name: Metadata
Select the image to use as the identifier: None
Select the metadata to use as the identifier: None
Export all measurements, using default file names?: Yes
Press button to select measurements to export: Cells\Children_DetectedBlobs_Count
Data to export: Do not use
Combine these object measurements with those of the previous object?: No
File name: DATA.csv
Use the object name for the file name?: Yes